Решение проблемы с установкой Wine-staging 4.13 на Linux Mint 19.2 Tina.

12. августа 2019 Linux, Wine 0

При установке winehq-staging 4.13 случилось неожиданное:

Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите, неосуществимо, или же вы используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
winehq-staging : Зависит: wine-staging (= 4.13~bionic)

Но неожиданное только в том случае, если в инструкции по установке не прочесть эту фразу:

Beginning with Wine 4.5, the wine-devel packages for Ubuntu 18.04, 18.10, and 19.04 require libfaudio0 as a dependency. Since the distro does not provide it, libfaudio0 packages can be downloaded from the OBS.

 

Решается эта незадача скачиванием пакета libfaudio0:
https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/

 

Для установки потребуется пакет =>libsdl2-2.0-0. Он потянет за собой следующие зависимости:
libasyncns0:i386
libdbus-1-3:i386
libfaudio0:i386
libflac8:i386
libgcrypt20:i386
libgpg-error0:i386
liblz4-1:i386
liblzma5:i386
libogg0:i386
libpulse0:i386
libsdl2-2.0-0:i386
libsndfile1:i386
libsndio6.1:i386
libsystemd0:i386
libvorbis0a:i386
libvorbisenc2:i386
libwayland-client0:i386
libwayland-cursor0:i386
libwayland-egl1:i386
libwrap0:i386
libxcursor1:i386
libxi6:i386
libxinerama1:i386
libxkbcommon0:i386
libxrandr2:i386
libxrender1:i386
libxss1:i386

Получается довольно обширный список.

Пример, как можно упростить задачу, выполнив установку всего необходимого в одну команду:
sudo apt install --install-recommends ~/Downloads/libfaudio0_19.07-0~bionic_i386.deb

Теперь можно без проблем установить winehq-staging 4.13:
sudo apt install --install-recommends winehq-staging